Announcement

Collapse
No announcement yet.

bit not moving high enough between letters

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bit not moving high enough between letters

    When engraving text the bit is going to the correct depth but when moving between letters does not raise high enough and cuts into the letter just engraved. I've tried to increase the Z gap setting in Vcarve Pro with no luck. Any suggestions will be appreciated. Thank you.

  • #2
    Can you post the file to look at?

    Comment


    • #3
      Thank you for the reply, about the file, sure thing, see the attached file.

      One thing is did notice is that there are several Z moves up to 0.4 but X & Y also move at the same time, I've been thinking of adding a line to command a separate Z move before these instances. Something like adding a line G01 X0.0277 Y0.3772 Z0.4000 between lines 71 and 72 or maybe replace the S0 c commands which I don't use with G01 Z0.4000. I think with a bit of fiddling I could get the file to work but having paid NWA and Vectric a pile of money I believe there should be a better than manually editing G code (TAP) files.

      Again thank you.
      Attached Files

      Comment


      • #4
        Please send the .crv file, I haven't gotten into the reading of G code yet. Thanks

        Comment


        • #5
          Here you go. Thanks.
          Attached Files

          Comment


          • #6
            You have your start depth set at .1 try setting it to 0.

            Comment


            • #7
              Hi Todd,
              Thank you for the reply, I started with the start depth at 0 then I first encountered the problem, changing to 0.1 was an attempt to fix the problem. It made the engraved text less deep bit I still had the bit touch the material in between letters. Anyway, I change it to 0 to look at the results again.

              Regards,
              Ed

              Comment


              • #8
                Hi Todd,
                I went back and noticed that there are multiple Post Processors, the one I was using was CNCPiranha-Laser (inch)(*.tap) out of curiosity I tried CNCPiranha-Arcs(inch) (*.tap) and see different results in the G code. The first with Laser in the name moves the bit to the safe position while moving in X &Y, see the code:

                G01 X0.0274 Y0.3823 Z-0.0313
                G01 X0.0277 Y0.3772 Z-0.0313
                S0
                F25.0
                G00 X0.4124 Y0.3615 Z0.4000
                G00 X0.4124 Y0.3615 Z-0.0313

                while the second with Arcs in the name holds the X&Y position while the bit moved up to the safe position and does not turn the spindle on/off.

                G01 X0.0274 Y0.3823 Z-0.0313
                G01 X0.0277 Y0.3772 Z-0.0313
                F25.0
                G00 X0.0277 Y0.3772 Z0.4000
                F25.0
                G00 X0.4124 Y0.3615 Z0.4000
                F15.0
                G1 X0.4124 Y0.3615 Z-0.0313

                Again, thanks for your help.

                Regards,
                Ed

                Comment


                • #9
                  What model cnc do you have? I have the Shark HD4 and use the CNCSHARK USB Arcs (inch) (*.tap) post processor.
                  Last edited by todd05060; 02-25-2020, 06:39 PM.

                  Comment


                  • #10
                    I have the small Piranha FX, like I said, when I use the CNCPiranha-Arcs(inch) (*.tap) Post all looks fine. My mistake was using the CNCPiranha-Laser(inch) (*.tap) Post.Looking at the G code I can understand what was happening..

                    Comment


                    • #11
                      Are you sure your material is flat, Are you setting z zero accurately? I would head over to the vetric forum for help, it is followed by a lot of experienced individuals, Post your file and they will have some suggestions for you. https://forum.vectric.com/

                      Comment


                      • #12
                        Hi Scott,
                        Thank you for the reply. As I mentioned earlier in this string I found out I was using the incorrect post processor. I discovered this by issue by investigating the gcode (.tap) file. Please see my post from Feb 25th.

                        Again, thanks for the reply.

                        Ed

                        Comment

                        Working...
                        X