Announcement

Collapse
No announcement yet.

Pendant not reading "New" files added to any USB formatted fat32

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pendant not reading "New" files added to any USB formatted fat32

    My shark pendant all of a sudden does not see new files added to any USB stick. I can see existing files on the stick however if I delete a file and add it again that file is not longer visible when the USB is plugged into the pendant.
    I've tried other USB sticks that have been formatted fat32 and have added a folder with files inside that folder to the newly formatted usb but the pendant can not see it.
    My working USB that I've been using since the machine was purchased the pendant can read files that have been on that stick since I placed them there. Now the only way my pendant can see "new files added" is if I add them to the root directory only. If I add any new files to the USB in a folder it can not be seen by the pendant.
    Trouble shooting measures I've taken.
    Purchased new USB and formatted to fat 32. I've added one folder with 3 new tap files in that folder using the same naming conventions that worked prior to this problem. Those files can not been seen by the pendant.
    I've added 6 tap files to the root directory of all USB sticks I have and those "new" files can be seen.
    I've unplugged everything from the control box cleaned it blew out the pendant to be sure clear of debris. Check that no wires are crossed and everything is free and clear.
    What do you think is my problem. I have not set up my laptop because I couldn't not figure out how to do this and now I've lost where those instructions are to give it another try.
    Thank you,
    Janet

  • #2
    Try a factory restore first. go to Apps > Factory Restore Defaults. Also it seems like you can see your files when they are placed in the root directory. Take one of your USBs that were working for you and empty it, you can copy the files to your PC so you don't lose them. Place 1 file in the root directory of that USB and try to run it. You'll also want to make sure you're using the same post processor as previously since changing that can also prevent the files from showing up on the LCD Pendant

    Comment


    • #3
      Yes, I can see files on any USB if I put them in the root directory including my working USB stick that has all my files that I use daily. The only thing I can no longer do is add any "new" files inside any folder, they have to be in the root directory only. I'm using the same post processor as always CNSshark-USB Arcs (Inch) (*.tap). If I remove all my working files from my work USB and add them back I will not be able to work at all except through the root directory and with my busy production schedule that is going to put me so far behind so I don't want to risk losing the files by doing that test.. I will try the reset. But...if that does not work, is it my pendant that needs to be replaced? If so where can I find comprehensive instructions for using my laptop instead? Thank you for your reply.

      Comment


      • #4
        My pendant won't read my file either. Somebody mentioned that my flash drive was too large. The smallest I could find was 16 GB at Best Buy so I'll give that a try. My other USB was 128 GB. The instructions say to use 8 G and under. Just trying to run a spoil board cut for my first cut. What size does everybody else use?

        Comment


        • #5
          Hi gsxrdemo,

          I use an old 2 gig usb to sneaker net the files from the pc to the cnc. I suspect you may be right about the drive size in the embedded os/runtime kernel they are using in the pendant. I have come across the issue in other embedded systems I need to work in, and even design with legance hardware and keep some small drives around for those reasons. I know i t doesn't solve your issue, but may shed some light on the problem. Since the .tap files are rather small the 2G that I use is more than large enough, assuming you can locate one. (The ones given away at tradeshows work great for this ;-). )

          My pendant for my Piranha won't read usb drives larger than 8g, though the display shows the usb is inserted, no files show up. It would be nice if nwa could provide technical documentation to the design to the community to allow us to help each other more.

          Good luck, let me know if it works with the smaller drive.
          Last edited by ninetomorrows; 01-06-2019, 11:39 AM.

          Comment


          • #6
            I think it was cause it's too hot in that part of my shop. So now when this happens I put the USB drive in the freezer for a few minutes and then I can see the files.

            Comment

            Working...
            X